This article provides procedures to configure the basic parameters of your Cisco router, including Global parameter settings, routing, Interface protocols, and command line access. It also describes the default configuration at startup. Note that individual router models may not support all the features described in this tutorial. Features that are not supported by a specific router will be highlighted.

Each section will have an example configuration and the exact steps to take, invite you to follow along.

Router ports

The following table lists the supported Interface for each router and their related ports on the device.

Router
Interface
Gate

Cisco 1801

Fast Ethernet LANs

SWITCH and FE8 – FE5 (top), FE x and FE4 – FE1 (bottom)

Fast Ethernet WANs

FE0

ATM WAN

ADSLoPOTS

Wireless LAN

LEFT, RIGHT / PRIMARY

BRI

ISDN S / T

Cisco 1802

Fast Ethernet LANs

SWITCH and FE8 – FE5 (top), FE x and FE4 – FE1 (bottom)

Fast Ethernet WANs

FE0

ATM WAN

ADSLoISDN

Wireless LAN

LEFT, RIGHT / PRIMARY

BRI

ISDN S / T

Cisco 1803

Fast Ethernet LANs

SWITCH and FE8 – FE5 (top), FE x and FE4 – FE1 (bottom)

Fast Ethernet WANs

FE0

ATM WAN

G.SHDSL

Wireless LAN

LEFT, RIGHT / PRIMARY

BRI

ISDN S / T

Cisco 1811

Fast Ethernet LANs

SWITCH and FE9 – FE6 (top), FE x and FE5 – FE2 (bottom)

Fast Ethernet WANs

FE0 – FE1

Wireless LAN

LEFT, RIGHT / PRIMARY

USB

1–0

V.92

MODEM

Cisco 1812

Fast Ethernet LANs

SWITCH and FE9 – FE6 (top), FE x and FE5 – FE2 (bottom)

Fast Ethernet WANs

FE0 – FE1

Wireless LAN

LEFT, RIGHT / PRIMARY

BRI

ISDN S / T

USB

1–0

See the default router configuration

When you start the Cisco router for the first time, some basic configuration has been done. All LAN and WAN interfaces have been created, the console and VTY ports have been configured, the internal interface for Network Address Translation has been specified. Use the command show running-config to see the initial configuration, as in the example below:

Note: If you cannot see the original configuration and receive an error message No Password Set, you must reset the original password.

Example: Cisco 1812 default configuration at startup

version 12.3 
service timestamps debug datetime msec 
service datestamps datetime log msec 
no service password-encryption 

hostname Router 

boot-start-marker 
boot-end-marker 

mmi polling-interval 60 
no mmi auto-configure 
no mmi pvc 
mmi snmp-timeout 180 
no aaa new-model 
ip subnet-zero 

ip cef 

po max i max-events 100 
no ftp-server write-enable 

interface BRI0 
no ip address 
shutdown 

interface FastEthernet0 
no duplex ip address 
shutdown 
auto 
speed auto 
!
interface FastEthernet1 
no ip address 
shutdown 
duplex auto 
speed auto 

interface FastEthernet2 
no ip address 
shutdown 

interface FastEthernet3 
no ip address 
shutdown 

interface FastEthernet4 
no ip address 
shutdown 

interface FastEthernet5 
no ip address 
shutdown 

interface FastEthernet6 
no ip address 
shutdown 

interface FastEthernet7 
no ip address 
shutdown 

interface FastEthernet8 
no ip address 
shutdown 

interface FastEthernet9
no ip address 
shutdown 

interface Vlan1 
no ip address 

ip classless 

no ip http server 
no ip http secure-server 

control-plane 

line con 0 
line aux 0 
line vty 0 4 

no scheduler allocate 
end

Information needed to configure the router

You will have to collect some or all of the following information, depending on the case.

If you are establishing an Internet connection, you will need the following information:

  • The Client Point-to-Point Protocol (PPP) name is assigned as the login name
  • PPP authentication type: Challenge Handshake Authentication Protocol (CHAP) or Password Authentication Protocol (PAP)
  • PPP password to access your Internet service provider (ISP) account
  • IP address of DNS server and default gateway

If you are establishing a connection to the corporate network , you and the network administrator must create and share the following information for the router's WAN interface:

  • PPP authentication type: CHAP or PAP
  • PPP client name to access router
  • PPP password to access the router

If you are setting up IP routing, you need:

  • Create an address map for your IP network
  • Determine IP routing parameter information, including: IP address, PVC. PVC parameters are usually virtual identifiers (VPI), virtual circuit identifiers (VCI) and traffic shaping parameters.
  • Determine the amount of PVC that the service provider provides to you, along with their VPI and VCI. Each PVC decides which type of AAL5 is supported, which can be one of the following:
    • AAL5SNAP: This type will have two cases: RFC 1483 routing and RFC 1483 bridge. For RFC 1483 routing, the service provider must provide you with a static IP address. For RFC 1483 bridges, you can use DHCP to get your IP address, or you can get a static IP address from your service provider.
    • AAL5MUX PPP: For this type, you need to identify configuration items related to PPP.

If you plan to connect via ADSL or G.SHDSL:

In this case you need to select the appropriate transmission from the provider.

  • For ADSL: Make sure that the ADSL signal type is DMT (also called ANSI T1.413) or DMT Issue 2.
  • For G.SHDSL: Verify whether the G.SHDSL transmission line complies with ITU G.991.2 standard.

Once you have all the information you need, you can fully configure your Cisco router, starting with the tasks in the basic configuration section.

Configure the basic parameters of Cisco routers

Configuring Global parameters

Follow the steps below to configure the Global parameters for your router:

 

Order

Purpose

Step 1

configure terminal

For example:

Router> enable

Router # configure terminal

Router (config) #

Enter Global configuration mode when using the console port.

If you are connecting to the router using a remote terminal, do the following:

telnet router name or address

Login: login id

Password: *********

Router> enable

Step 2

hostname name

For example:

Router (config) # hostname Router

Router (config) #

Name the router.

Step 3

enable secret password

For example:

Router (config) # enable secret cr1ny5ho

Router (config) #

Specify an encrypted password to prevent unauthorized access to the router.

Step 4

no domain-lookup ip

For example:

Router (config) # no domain-lookup ip router (config) #

Turn off the auto-resolution of the wrong entries (due to typing errors) to IP addresses.

 

Fast Ethernet LAN Interface configuration

The Fast Ethernet LAN Interface on your router is automatically configured as part of the default VLAN and therefore they are not configured with individual addresses. Access is provided through VLAN. You can assign interfaces to other VLANs if you want.

Configure WAN Interface

Cisco 1811 and Cisco 1812 routers have two Interface Fast Ethernet for WAN connectivity. Cisco 1801, Cisco 1802 and Cisco 1803 routers have an ATM Interface for WAN connectivity.

Based on the router model you have, configure WAN with one of the following procedures:

WAN configuration Fast Ethernet Interface: This procedure only applies to Cisco 1811 and Cisco 1812 router models. Perform the following steps to configure the Fast Ethernet Interface, starting in Global configuration mode.

 

Order

Purpose

Step 1

interface type number

For example:

Router (config) # interface fastethernet 0
Router (config-int) #
 

Enter Interface Fast Ethernet WAN configuration mode on the router.

Note: WAN Fast Ethernet ports are numbered 0-1 on Cisco 1800 series routers.

 

Step 2

ip address ip-address mask

For example:

Router (config-int) # ip address 192.1.12.2 255.255.255.0
Router (config-int) #

Set the IP address and subnet mask for Interface Fast Ethernet specified.

Step 3

no shutdown

For example:

Router (config-int) # no shutdown
Router (config-int) #

Turn on Ethernet Interface, change its status from off to enabled (administratively down to administratively up).

Step 4

exit

For example:

Router (config-int) # exit
Router (config) #

Exit Interface configuration mode and return to Global configuration mode.

Repeat the above steps for other interfaces if you need to.

Configuring Interface WAN ATM: This procedure only applies to Cisco 1801, Cisco 1802 and Cisco 1803 models. Perform the following steps to configure Interface ATM, starting in Global configuration mode:

 

Order

Purpose

Step 1

For Cisco 1803 only:

controller dsl 0 
mode atm 
exit

For example:

Router (config) # controller dsl 0
Router (config-controller) # mode atm
Router (config-controller) # exit
Router (config) #

For routers using G.SHDSL signal, execute these commands. If the router uses ADSL signal then ignore.

Step 2

interface type number

For example:

Router (config) # interface atm0
Router (config-int) #
 

Go to Interface configuration mode.

Step 3

ip address ip-address mask

For example:

Router (config-int) # ip address 200.200.100.1 255.255.255.0
Router (config-int) #
 

Set IP address and subnet mask for Interface.

Step 4

no shutdown

For example:

Router (config-int) # no shutdown
Router (config-int) #
 

Enable Interface ATM 0.

Step 5

exit

For example:

Router (config-int) # exit
Router (config) #
Exit Interface configuration mode and return to Global configuration mode.

Wireless Interface configuration

Wireless Interface allows connecting to the router via a wireless LAN connection. For more information about this wireless configuration, you can consult more on cisco.com. I will try to add more later.

Configure Loopback Interface 

The Loopback Interface acts as a placeholder for static IP addresses and provides default routing information. To configure this Interface, follow these steps:

 

Order

Purpose

Step 1

interface type number

For example:

Router (config) # interface Loopback 0
Router (config-int) #
 

Go to Interface configuration mode.

Step 2

ip address ip-address mask

For example:

Router (config-int) # ip address 10.108.1.1 255.255.255.0
Router (config-int) #
 

Set the IP address and subnet mask for Loopback Interface.

Step 3

exit

For example:

Router (config-int) # exit
Router (config) #
 

Exit the Loopback Interface configuration mode and return to Global configuration mode.

Configuration example:

Loopback Interface in this model configuration is used to support Network Address Translation (NAT) on virtual model Interface. This example shows that the Loopback Interface is configured on Interface Fast Ethernet with an IP address of 200,200.100.1/24, acting as a static IP. Loopback Interface points to virtual-template1 with a dynamic IP address.


interface loopback 0 
ip address 200.200.100.1 255.255.255.0 (static IP address) 
ip nat outside 

interface Virtual-Template1 
ip unnumbered loopback0 
no directed-broadcast 
ip ip outside

Confirm configuration:

To confirm that you have correctly configured the Loopback Interface, enter the show interface command, you will see a confirmation result similar to the example below:

Router # show interface loopback 0 
Loopback0 is up, line protocol is up 
Hardware is loopback 
Internet address is 200.200.100.1/24 
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, 
reliability 255/255, txload 1/255, rxload 1 / 255 
Encapsulation LOOPBACK, loopback not set 
Last input never, output never, output hang never 
Last clearing của "show interface" counters Never 
Queue strategy: fifo 
Output queue 0/0, 0 drops; queue input 0/75, 0 drops 
5 minute input rate 0 bits / sec, 0 packets / sec 
5 minutes output rate 0 bits / sec, 0 packets / sec 
0 packets input, 0 bytes, 0 no buffer 
Received 0 broadcasts, 0 runts , 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
0 packets output, 0 bytes, 0 underruns 
0 output errors, 0 collisions, 0 interface resets 
0 output buffer failures, 0 output buffers swapped out

Another way to confirm Loopback Interface is to ping it:

Router # ping 200.200.100.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min / avg / max = 1/2/4 ms

Configure the Command-Line to access the Router

Follow the steps below to configure the Command-Line Router access:

 

Order

Purpose

Step 1

line [ aux | console | tty | vty ] line-number

For example:

Router (config) # line console 0
Router (config) #
 

Access the command line configuration mode and specify the command line type. This example specifies the console terminal to access.

Step 2

password

password

For example:

Router (config) # password 5dr4Hepw3
Router (config) #
 

Specify a unique password for console terminal.

Step 3

login

For example:

Router (config) # login
Router (config) #
 

Turn on password checking when logging in to the terminal.

Step 4

exec-timeout minutes [ seconds ]

For example:

Router (config) # exec-timeout 5 30
Router (config) #
 

Set the time that the EXEC command interpreter waits until the received user information is received. The default is 10 minutes. You can add more seconds if you want.

In this example, the waiting time is 5 minutes 30 seconds. If entering 0 0 means never wait.

Step 5

line [ aux | console | tty | vty ] line-number

For example:

Router (config) # line vty 0 4
Router (config) #
 

Specify a virtual terminal to access the remote console.

Step 6

password

password

For example:

Router (config) # password aldf2ad1
Router (config) #
 

Set a password for the virtual terminal.

Step 7

login

For example:

Router (config) # login
Router (config) #
 

Turn on password checking when logging into the virtual terminal.

Step 8

end

For example:

Router (config) # end
Router #
 

Exit the command line configuration mode and return to Privileged EXEC mode.

Configuration example:

The following sample configuration will display command line access commands. You do not need to enter the commands marked "default". These commands will appear automatically in the configuration file, created when you use the command show running-config .


line child 0 
exec-timeout 10 0 
password 4youreyesonly 
login 
transport none (default) 
1 (default) 
line vty 0 4 
password secret 
login 
!

Configure static routes (static routes)

Static routes provide fixed routing paths on the network. They are manually configured on the router. If the network topology changes, static routing must be updated to the new routing. Static routes are separate routes, unless they are redistributed by routing protocols. Configuring static routing on Cisco 1800 series routers is optional. Follow the steps below to configure, starting from Global configuration mode:

 

Order

Purpose

Step 1

ip route prefix mask { ip-addressinterface-type interface-number [ ip-address ]}

For example:

Router (config) # ip route 192.168.1.0 255.255.0.010.10.10.2
Router (config) #
 

Specify static routing for IP packets.

Step 2

end

For example:

Router (config) # end
Router #
 

Exit static routing configuration mode, enter Privileged EXEC mode.

Configuration example:

In this example, the static route will send all IP packets with the destination IP address of 192.168.1.1 and subnet mask of 255.255.255.0 on Interface Fast Ethernet to IP address 10.10.10.2. Specifically, packets are sent to a configured PVC. 

You do not need to enter the commands marked "default". These commands will appear automatically in the configuration file, created when you use the command show running-config .


classless ip (default) 
ip route 192.168.1.0 255.255.255.0 10.10.10.2!

Confirm configuration:

To confirm if you have configured the static route correctly, enter the show ip routecommand and find the static route represented by "S". Confirmation results will look like this:

Router # sh o w ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP 
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
N1 - OSPF NSSA OSPF NSSA type 2 - OSPF NSSA type 2, 
E1 - OSPF type 1, E2 - OSPF type 2 external 
- IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS- IS 
-IS inter-IS, IS-IS inter area, * - candidate default, U - per-user static route 
o - ODR, P - period of static download route 

Gateway of last resort is not set 

10.0.0.0/24 is subnetted, 1 subnets 
C 10108.1.0 is directly connected, Loopback0 
S * 0.0.0.0/0 is directly connected, FastEthernet0

Dynamic routing configuration (Dynamic Route)

In dynamic routing, the network protocol adjusts the automatic path, based on network traffic or topology. Changes in dynamic routing will be shared with other routers in the network. Cisco routers can use IP routing protocols such as the Routing Information Protocol (RIP) or the Enhanced Interior Gateway Routing Protocol (EIGRP) to generate dynamic routing. You can also configure several routing protocols on your router.

Configure RIP

To configure RIP you do the following, starting from Global configuration mode:

 

Order

Purpose

Step 1

rip router

For example:

Router> configure terminal
Router (config) # rip router
Router (config-router) #
 

Enter router configuration mode and turn on RIP on the router.

Step 2

version {1 | 2}

For example:

Router (config-router) # version 2
Router (config-router) #
 

Specify whether to use RIP version 1 or 2.

Step 3

network ip-address